FlySim.com Forum Index FlySim.com
FlySim and KiteSim Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Corrupted file

 
Post new topic   Reply to topic    FlySim.com Forum Index -> FlySim Discussion
View previous topic :: View next topic  
Author Message
syrenstomb



Joined: 13 May 2006
Posts: 10

PostPosted: Sat May 13, 2006 1:13 am    Post subject: Corrupted file Reply with quote

Hello, I have a problem, I ran the demo on my computer at work (I know I know bad me) and decided to buy the game (too much fun) and install it at home, well here is the problem for some reason I get an error that the OpenAL32.dll is corrupt or missing. Its in the folder but for some reason my home comp doesnt recognize it. As I am on modified telegraph here at home the new drivers are slowly trickling in, dont know if that will help or not. Any suggestions if it doesn't? Im running XP Pro on a year old system if you want specs I can post them.
Back to top
View user's profile Send private message Yahoo Messenger
J.R.



Joined: 20 May 2005
Posts: 73

PostPosted: Sat May 13, 2006 2:26 am    Post subject: Reply with quote

OpenAL is sound library we distribute with FlySim. Reinstalling FySim may fix your problem. If not, please let me know.

-J.R.
Back to top
View user's profile Send private message
syrenstomb



Joined: 13 May 2006
Posts: 10

PostPosted: Mon May 15, 2006 4:23 pm    Post subject: Reply with quote

No I tried that 4 or 5 times, I keep getting the same error.
Back to top
View user's profile Send private message Yahoo Messenger
J.R.



Joined: 20 May 2005
Posts: 73

PostPosted: Mon May 15, 2006 10:55 pm    Post subject: Reply with quote

Please take a look at:

C:\Program Files\FlySim

Do you see OpenAL32.dll there?

If so, double click "flysim.exe" - does it run?
Back to top
View user's profile Send private message
syrenstomb



Joined: 13 May 2006
Posts: 10

PostPosted: Tue May 16, 2006 1:14 am    Post subject: Reply with quote

It is there and no it doesnt run. Full error reads
Cannot find import; DLL may be missing. corrupt, or wrong version File "OpenAL32.dll", error 998
Back to top
View user's profile Send private message Yahoo Messenger
J.R.



Joined: 20 May 2005
Posts: 73

PostPosted: Tue May 16, 2006 2:23 am    Post subject: Reply with quote

Take a look in C:\WINDOWS\system32
Is there an OpenAL32.dll there? If so, rename it to OpenAL32XXX.dll and try again.
I think that windows is supposed to search locally before system32, but it's worth a try.

Another thing to try is to copy the OpenAL32.dll to system32.
Back to top
View user's profile Send private message
syrenstomb



Joined: 13 May 2006
Posts: 10

PostPosted: Tue May 16, 2006 7:08 pm    Post subject: Reply with quote

ok Ill give that a go..
Back to top
View user's profile Send private message Yahoo Messenger
syrenstomb



Joined: 13 May 2006
Posts: 10

PostPosted: Wed May 17, 2006 1:23 am    Post subject: Reply with quote

tried both options, re-installed sound drivers, re-installed video, tried using a copy of the file from my work computer, uninstalled/re-installed post driver updates. No go....
Back to top
View user's profile Send private message Yahoo Messenger
J.R.



Joined: 20 May 2005
Posts: 73

PostPosted: Wed May 17, 2006 4:56 pm    Post subject: Reply with quote

This is a tough one.

The only thing that makes any sense is that an alternate OpenAL32.dll is being loaded.

Can you search your system for "OpenAL32.dll" and rename any you find - except the one in C:\Program Files\FlySim
Back to top
View user's profile Send private message
syrenstomb



Joined: 13 May 2006
Posts: 10

PostPosted: Wed May 17, 2006 6:18 pm    Post subject: Reply with quote

Alright I'll check it out.
Back to top
View user's profile Send private message Yahoo Messenger
syrenstomb



Joined: 13 May 2006
Posts: 10

PostPosted: Wed May 17, 2006 8:40 pm    Post subject: Reply with quote

Ok I am apparently destined not to play this at home...I did the search found the file in the fly sim program folder and in the sys32 folder. Renamed the sys32 copy like you said before. Still getting the same error. Dont know what else to do I've asked a couple of different people now and cant get a working solution.
Back to top
View user's profile Send private message Yahoo Messenger
syrenstomb



Joined: 13 May 2006
Posts: 10

PostPosted: Wed Jun 28, 2006 1:09 am    Post subject: Reply with quote

Hello again!! Well I solved the problem and I can now run FlySim at home. Bully for me! I downloaded the .dll file from

http://www.dll-file.net/files/dll/openal32.html

I copied this new .dll file to the Fly Sim folder replacing the one there and BAM all is better now. Loaded, registered and playing. Since I did get a good install on my other computer will there be a problem activating that copy as well?
Back to top
View user's profile Send private message Yahoo Messenger
J.R.



Joined: 20 May 2005
Posts: 73

PostPosted: Sat Jul 01, 2006 2:52 pm    Post subject: Reply with quote

Cool - I will look into updating our OpenAL dll.
If you have any troubles activating, please email.

-J.R.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    FlySim.com Forum Index -> FlySim Discussion All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group